<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lato:300,400,900,900italic,300italic,400italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Rowan County man charged in overdose death of Cleveland couple - Salisbury Post | Salisbury Post</title>

        <!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GOOGLE_TAG_MANAGER_ID');</script>
<!-- End Google Tag Manager -->
        <meta name="viewport" content="width=device-width, initial-scale=1">

				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.min.css?1599406936" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1599406936" />
				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/css/normalize.css?1599406936" />
				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/css/base.css?1599406936" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/style.css?1599406936" />

        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/modernizr-2.6.2.min.js?1599406936"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.salisburypost.com/wp-content/themes/2016-salisbury-mobile-child/media/img/brand/favicon-salisburypost.png">
				<link rel="apple-touch-icon" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/images/brand/apple-touch-icon.png" />

				
																
<!-- This site is optimized with the Yoast SEO plugin v12.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rowan County man charged in overdose death of Cleveland couple - Salisbury Post" />
<meta property="og:description" content="CLEVELAND — A Rowan County man faces felony charges related to the overdose death of a Cleveland couple four months after they were found dead inside their home. Marcus Anthony Eudy, 28, of Grampian Road, became a suspect after he allegedly sold narcotics to the couple, Susan Elaine Childers and Marty Franklin Childers, both 53. &hellip;" />
<meta property="og:url" content="https://www.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/" />
<meta property="og:site_name" content="Salisbury Post" />
<meta property="article:section" content="Crime" />
<meta property="article:published_time" content="2020-10-12T15:35:28-04:00" />
<meta property="og:image" content="https://salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg?w=240" />
<meta property="og:image:secure_url" content="https://salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg?w=240" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="CLEVELAND — A Rowan County man faces felony charges related to the overdose death of a Cleveland couple four months after they were found dead inside their home. Marcus Anthony Eudy, 28, of Grampian Road, became a suspect after he allegedly sold narcotics to the couple, Susan Elaine Childers and Marty Franklin Childers, both 53. [&hellip;]" />
<meta name="twitter:title" content="Rowan County man charged in overdose death of Cleveland couple - Salisbury Post" />
<meta name="twitter:image" content="https://salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg?w=240" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://m.salisburypost.com/#website","url":"https://m.salisburypost.com/","name":"Salisbury Post","potentialAction":{"@type":"SearchAction","target":"https://m.salisburypost.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/#primaryimage","url":"https://salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg?w=240"},{"@type":"WebPage","@id":"https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/#webpage","url":"https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/","inLanguage":"en-US","name":"Rowan County man charged in overdose death of Cleveland couple - Salisbury Post","isPartOf":{"@id":"https://m.salisburypost.com/#website"},"primaryImageOfPage":{"@id":"https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/#primaryimage"},"datePublished":"2020-10-12T15:35:28-04:00","dateModified":"2020-10-12T15:35:28-04:00","author":{"@id":"https://m.salisburypost.com/#/schema/person/4b96d8c59db1fee7e10bc05ccf617a55"}},{"@type":["Person"],"@id":"https://m.salisburypost.com/#/schema/person/4b96d8c59db1fee7e10bc05ccf617a55","name":"Shavonne Potts","image":{"@type":"ImageObject","@id":"https://m.salisburypost.com/#authorlogo","url":"https://m.salisburypost.com/wp-content/uploads/sites/9/2020/08/Walker-Shavonne.jpg?w=78","caption":"Shavonne Potts"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.salisburypost.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Salisbury Post &raquo; Rowan County man charged in overdose death of Cleveland couple Comments Feed" href="https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/m.salisburypost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://m.salisburypost.com/_static/??-eJxljFEKgCAQBS9UbiFCfkRnURPaMg3XKG+fBEXQ32PeMHBsNXrj9tESGCIYFU1ogie2omeFVPBVZoJU/kWH8x1/6w4hJdAumKV2qKOKGShlZ5/usPatkJ2QvOH8Am77MQM=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.salisburypost.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.6' media='all' />
<link rel='stylesheet' id='m1mw-css'  href='https://www.salisburypost.com/wp-content/plugins/m1miniweather-bni-.0.2.b/css/weather-icons.min.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://m.salisburypost.com/wp-includes/css/admin-bar.min.css?m=1598593033g' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<link rel='stylesheet' id='wp-polls-css'  href='https://www.salisburypost.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' media='all' />
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.salisburypost.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.salisburypost.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/style.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://www.salisburypost.com/wp-content/themes/2016-salisbury-mobile-child/style.css?ver=1599406936' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.salisburypost.com/wp-content/mu-plugins/jetpack-9.0/css/jetpack.css?ver=9.0.2' media='all' />
<script src='https://m.salisburypost.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {

		var searchValRegex = new RegExp( $(this).val(), 'i');

		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {

			return searchValRegex.test( $(this).find('> a').text() );

		}).show();

	});
});
	
</script>
<script type='text/javascript' src='https://m.salisburypost.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1598593033g'></script>
<link rel='https://api.w.org/' href='https://m.salisburypost.com/wp-json/' />
<link rel='shortlink' href='https://m.salisburypost.com/?p=479898' />
<link rel="alternate" type="application/json+oembed" href="https://m.salisburypost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.salisburypost.com%2F2020%2F10%2F12%2Frowan-county-man-charged-in-overdose-death-of-cleveland-couple%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://m.salisburypost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.salisburypost.com%2F2020%2F10%2F12%2Frowan-county-man-charged-in-overdose-death-of-cleveland-couple%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style><!-- Global site tag (gtag.js) - Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-34177675-1', 'auto');
  ga('send', 'pageview');
</script>
											<script type="text/javascript">
					document.write(unescape("%3Cscript src='https://subscriptions.salisburypost.com/bwtw/scripts/tw.js' type='text/javascript'%3E%3C/script%3E"));
				</script>
				<script type="text/javascript">

          _bwtp = new TheWall('https://subscriptions.salisburypost.com/bwtw/', 'SP', 'SP', null, 'DEFAULT');

          var pw_total_val = '0';
          var pw_read_val = '0';

					_bwtp.init();
          loggedin = _bwtp.userStatus();
          _bwtp.status(function(f) { 
            pw_total_val = f.viewRate.AllowedViews;
            pw_read_val = f.viewRate.NumViews;
          });

					jQuery(window).load(function() { // These functions get called when everything has loaded
						if (!loggedin) {
							jQuery("#slidebarList").prepend('<li><a href="#" onclick="_bwtp.Auth(true);">Log In</a></li>');
              if (( pw_total_val > 0 ) && ( pw_read_val <= pw_total_val ) && ( jQuery('body').attr("id") != "homePage")) {
                var paywall_info_content = '<div id="paywall_info_box" style="padding: 1em 0; margin: 1em 0; font-weight: bold; border-top: 1px solid #aaa; border-bottom: 1px solid #aaa; text-align: center; color: #222;">' +
                  '<p style="font-weight: bold;">You have read ' + pw_read_val + ' of ' + pw_total_val + ' articles.</p>' +
                  '<p style="margin-bottom: 0; font-weight: bold;"><a href="#" onclick="_bwtp.Auth(true);" style="color: #92191f;">Log In or Subscribe</a></p>' + 
                  '</div>';
                jQuery(paywall_info_content).appendTo('div#article div.byline').fadeIn();
              }

						} else {
							jQuery("#slidebarList").prepend('<li><a href="#" onclick="_bwtp.clearID();">Log Out</a></li>');
						}
					});
				</script>


				<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>



    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>

googletag.cmd.push(function() {
    			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/SNL-m-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/SNL-m-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }
    

			googletag.defineSlot('/1613683/SNL-m-320x50-1', [320, 50], 'div-gpt-ad-mobile-leader').addService(googletag.pubads());
			BIGBLOCK_AD_ONE = googletag.defineSlot('/1613683/SNL-m-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			BIGBLOCK_AD_TWO = googletag.defineSlot('/1613683/SNL-m-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			BIGBLOCK_AD_THREE = googletag.defineSlot('/1613683/SNL-m-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-6', [300, 250], 'div-gpt-ad-bigblock-6').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());
  if (!loggedin) {
			googletag.defineOutOfPageSlot('/1613683/SNL-m-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-320x50-sticky', [[320, 50], [1, 1]], 'div-gpt-ad-mobile-sticky').addService(googletag.pubads());
  }

                  googletag.pubads().setTargeting("catname", [ "crime", "local", "news", "top-home",  ]);
          
          googletag.pubads().setTargeting("pageurl", "/2020/10/12/rowan-county-man-charged-in-");
    
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });

		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
		googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/SNL-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/SNL-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/SNL-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/SNL-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/SNL-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/SNL-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/SNL-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/SNL-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/SNL-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/SNL-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/SNL-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/SNL-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/SNL-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/SNL-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/SNL-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/SNL-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/SNL-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/SNL-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/SNL-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/SNL-320x50-1',
          sizes: [[320, 50], [1, 1]]
      }
     ],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


<script>
   var otkjs = otkjs || {};
    /**
     * Add any divs to refresh.
     * 
     * Parameters:
     * 1. Array of divs w/parameter to refresh, can be one or many:
     *  - DIV_ID: The DOM div id of the ad position
     *  - MIN_TIME_IN_VIEW: The amount of time the ad must be 
     *      in view before being eligible to be refreshed, we recommend at least 1.1 seconds
     *  - MIN_TIME_ON_PAGE: The amount of time the ad must be in von the page before refreshing 
     *  - TARGETING: Array of key/value targeting for the ad slot.
     * 
     * NOTE: The ad will on refresh once the parameters are met and the ad is
     * is currently in view.
     * 
     * Function:
     * otkjs.addRefresh(
     * Array[
     *    Array[DIV_ID, MIN_TIME_IN_VIEW, MIN_TIME_ON_PAGE, TARGETING[Array['key', 'value']]
     * ]);
     * 
     * Example - add two ad divs to be refreshed:
     *   otkjs.addRefresh([
     *     ['div-1', 1.1, 30, [['key2', 'value2'], ['refresh', 'true']]],
     *     ['div-2', 1.1, 30, [['key4', 'value4'], ['refresh', 'true']]]
     *   ]);
     */
      var mt_in_view = 1.2
      var mt_on_page = 34

      otkjs.addRefresh([
        //['div-1', mt_in_view, mt_on_page, [['refresh', 'true']]]
        ['div-gpt-ad-extra_one_by_one', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_oop', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one_two', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-leader', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-2', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-3', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-4', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-5', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-6', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-halfpage-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-screenshift', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-sticky', mt_in_view, mt_on_page, [['refresh', 'true']]],
      ]);
  </script>
        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/qgm--t1cSnkJXHwvoo7JKXT4-fniaL7GoKdYaAHjVpaT3LGQD-2yOxsw17xqTxCsa1eU6UZ1N43JR0",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>


<meta property="fb:app_id" content="168913723140235" />

                        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
        
    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
        <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GOOGLE_TAG_MANAGER_ID"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_acby66y5aly33aqou3rkicnpnu'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div class="undertone">

				<div class="mobile-nav sb-slide">
									<div class="sb-toggle-left navbar-left">
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
					</div><!-- /.sb-control-left -->
					<a href="https://m.salisburypost.com">
						<img class="logo" src="https://www.salisburypost.com/wp-content/themes/2016-salisbury-mobile-child/media/img/brand/logo-white-salisburypost.png" alt="Salisbury Post" />
					</a>
					<div class="search">
						<a href="#" class="expand">expand</a>
						<form method="get" class="searchForm" action="https://m.salisburypost.com/site-search">
							<input type="submit" class="searchButton" value="Go" />
							<input type="text" name="q" class="searchQuery" value="Search Salisbury Post..." onfocus="if(this.value=='Search Salisbury Post...'){this.value='';}" onblur="if(this.value==''){this.value='Search Salisbury Post...';}" />
						</form>
					</div>
				</div>

				<div id="sb-site">
					<!-- Add your site or application content here -->
					<div class="upper_ad">
						<div class="wrapper">
							<div class="ad">
								<div class="ad720x90">Ad Spot</div>
							</div>
						</div>
					</div>
					<div class="sup_nav">
						<div class="wrapper">
														<p class="date">
								October 12, 2020							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div class="wrapper">
						<header>
							<nav id="navbar">
								<ul id="mainNav">
	<li class=""><a href="https://subscriptions.salisburypost.com/CircStore/Account/Login?vendor=DirXion&prodId=SP">E-edition</a></li>
  <li><a href="https://m.salisburypost.com/customer-service/">Submit</a></li>
	<li class="home "><a href="https://m.salisburypost.com">Home</a></li>
  <li><a href="https://m.salisburypost.com/category/news/local/" title="Local News | Salisbury, North Carolina - The Salisbury Post">Local</a></li>
	<li class="subscribe"><a href="http://www.salisburypost.com/subscriptions/">Subscriptions</a></li>
	<li class="classifieds"> <a href="https://marketplace.salisburypost.com/adhunter/SalisburyPost/">Classifieds</a> </li>
	<li class="news "> <a href="https://m.salisburypost.com/category/news/">News</a></li>
  <li><a href="https://m.salisburypost.com/category/business/" title="Business News | Salisbury, North Carolina - The Salisbury Post">Business</a></li>
  <li><a href="https://m.salisburypost.com/category/news/politics/" title="Politics | Salisbury, North Carolina - The Salisbury Post">Politics</a></li>
  <li><a href="https://m.salisburypost.com/category/crime/" title="Crime | Salisbury, North Carolina - The Salisbury Post">Crime</a></li>
  <li><a href="https://m.salisburypost.com/category/news/kannapolis/" title="Kannapolis News | Salisbury, North Carolina - The Salisbury Post">Kannapolis</a></li>
  <li><a href="https://m.salisburypost.com/category/opinion/" title="Opinion | Salisbury, North Carolina - The Salisbury Post">Opinion</a></li>
	<li class="sports"> <a href="https://m.salisburypost.com/category/sports/">Sports</a> </li>
  <li><a href="https://m.salisburypost.com/category/sports/high-school/" title="High School Sports | Salisbury, North Carolina - The Salisbury Post">High School</a></li>
  <li><a href="http://racing.ap.org/salisburypost/" title="NASCAR - The Salisbury Post">Nascar</a></li>
  <li><a href="http://pro32.ap.org/salisburypost/" title="Pro Football - The Salisbury Post">Pro Football</a></li>
	<li class="lifestyle"> <a href="https://m.salisburypost.com/category/lifestyle/">Life</a> </li>
	<li class="obituaries"><a href="http://www.legacy.com/obituaries/salisburypost/">Obits</a></li>
	<li class=""><a href="http://salisburypost.nc.newsmemory.com/ssindex.php">Special Sections</a></li>
  <li class=""><a href="http://salisburypost.mycapture.com/mycapture/index.asp">Photos</a></li>
	<li class=""><a href="http://www.salisburythemagazine.com/">SALISBURY the Magazine</a></li>
  <li class="RoCo Gold"><a href="http://www.rocogold.com">RoCo Gold Awards</a></li>  
  <li><a href="https://m.salisburypost.com/category/spirit-of-rowan/">Spirit of Rowan</a></li>
  <li><a href="https://m.salisburypost.com/customer-service/">Contact Us</a></li>
  <li><a href="https://marketplace.salisburypost.com/Salisbury/">Place an Ad</a></li>

		
</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content">
							<div id="notifications">
								






								


								
								
							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  </script>
</div>	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  </script>
</div></div>

	
							<div class="ad first">
								<!-- 320x50_mobile_leader -->
<div id='div-gpt-ad-mobile-leader'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-leader'); });
  </script>
</div>							</div>



							<div class="main_column">
								<div class="story">
									
									
                      <div class="prev_next_article">
  <!-- v 1.61 -->
          <div class="prev_article">
        <div class="padding">
          <a href="https://m.salisburypost.com/2020/10/12/political-notebook-two-local-candidates-drop-out-of-rowan-chamber-of-commerce-forum/" class="arrow left button">
            <svg width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            45.63,75.8 0.375,38.087 45.63,0.375 "/>
            </svg>  
          </a>
        </div>
      </div>
    
                              <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <div class="thumb">
            <a href="https://m.salisburypost.com/2020/10/12/political-notebook-two-local-candidates-drop-out-of-rowan-chamber-of-commerce-forum/">
              <img src="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/04/political-notebook-logo.jpg?w=90&h=90&crop=1" alt="" width="50" height="50">
            </a>
          </div>
                    <h4> <a href="https://m.salisburypost.com/2020/10/12/political-notebook-two-local-candidates-drop-out-of-rowan-chamber-of-commerce-forum/">Political Notebook: Two local candidates drop out of Rowan&hellip;</a> </h4>
          <a href="https://m.salisburypost.com/2020/10/12/political-notebook-two-local-candidates-drop-out-of-rowan-chamber-of-commerce-forum/" class="arrow right button">
            <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            0.375,0.375 45.63,38.087 0.375,75.8 "/>
            </svg>
          </a>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    

              </div>
    </div>
		
									<div id="leftRail" class="">
																			</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>Rowan County man charged in overdose death of Cleveland couple</h2>

										<div class="byline">
											
											<a href="https://m.salisburypost.com/author/shavonne.potts/" rel="bookmark">
                        <img width="98" height="120" src="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/08/Walker-Shavonne.jpg?w=98" class="avatar avatar-120 photo" alt="" srcset="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/08/Walker-Shavonne.jpg 600w, https://m.salisburypost.com/wp-content/uploads/sites/9/2020/08/Walker-Shavonne.jpg?resize=245,300 245w, https://m.salisburypost.com/wp-content/uploads/sites/9/2020/08/Walker-Shavonne.jpg?resize=286,350 286w, https://m.salisburypost.com/wp-content/uploads/sites/9/2020/08/Walker-Shavonne.jpg?resize=40,50 40w" sizes="(max-width: 98px) 100vw, 98px" />											</a>

											<p class="author">
												<strong>By <a href="https://m.salisburypost.com/author/shavonne.potts/" rel="bookmark">Shavonne Potts</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:shavonne.walker@salisburypost.com">Email the author</a>
																								 | 
													<a href="https://twitter.com/SalPostPotts" target="_blank">twitter</a>
																							</p>
											<p class="pubStamp">Published 11:35 am Monday, October 12, 2020</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  </script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  </script>
</div>                    </div>

										<div class="p402_premium">


										
										<div class="story_detail">
                      <div class="read_more_wrap">
                        
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>var TRINITY_TTS_WP_CONFIG = {"cleanText":"Rowan County man charged in overdose death of Cleveland couple. CLEVELAND \u2014 A Rowan County man faces felony charges related to the overdose death of a Cleveland couple four months after they were found dead inside their home.\r\n\r\nMarcus Anthony Eudy, 28, of Grampian Road, became a suspect after he allegedly sold narcotics to the couple, Susan Elaine Childers and Marty Franklin Childers, both 53. Warrants for Eudy were obtained for two counts of death by distribution.\r\n\r\nThe couple were found on June 7 at their home in the 600 block of Childers Road by their son.\r\n\r\n\r\n\r\nThe Rowan County Sheriff's Office deputies responded to the home to investigate a suspicious double death. Detectives executed a search warrant at the residence and there were no signs of foul play at the scene. Suspected narcotics and narcotic paraphernalia were located and subsequently sent to the N.C. Crime lab, said Maj. John Sifford.\r\n\r\nAutopsy reports showed both victims died from acute fentanyl poisoning along with other narcotic and alcohol intoxications. The N.C. State crime lab results confirmed that the items collected at the scene contained fentanyl.\r\n\r\nOne of the victim's phones contained text messages in which there was communication with Eudy about the purchase of narcotics. Search warrants were obtained on all the phones and phone numbers associated with the case, according to a statement.\r\n\r\nLast week, a search warrant for Eudy's phone number confirmed he was the individual who had communication with the victims during the drug transaction, Sifford said.\r\n\r\nEudy was arrested on Sunday and placed in the Rowan County Detention Center under a $250,000 secured bond. Sifford said more charges are expected.\r\n\r\nAnyone with information is asked to call Detective Travis Allen at 704-216-8715, First Sgt. Ollie Greene, First Lt. Rodney Mahaley or Crime Stoppers 1-866-639-5245.","pluginVersion":"2.4.0"};</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=677143c5c1f3a1a2fcc0862c5951f602&postHash=ed9ef89bf423bff3ea5bc794f84c541c&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><p>CLEVELAND — A Rowan County man faces felony charges related to the overdose death of a Cleveland couple four months after they were found dead inside their home.</p>
<p>Marcus Anthony Eudy, 28, of Grampian Road, became a suspect after he allegedly sold narcotics to the couple, Susan Elaine Childers and Marty Franklin Childers, both 53. Warrants for Eudy were obtained for two counts of death by distribution.</p>
<div id='mydfpad' class='ad300x ad'>
            <div id='div-gpt-ad-bigblock-1'>
              <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-1'); });
              </script>
            </div>
          </div>
          <div id='cedato-unit'></div><p>The couple were found on June 7 at their home in the 600 block of Childers Road by their son.</p>
<div id="attachment_479923" style="width: 250px" class="wp-caption alignnone"><a href="https://salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg"><img aria-describedby="caption-attachment-479923" class="wp-image-479923 size-medium" src="https://salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg?w=240" alt="" width="240" height="300" srcset="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg 480w, https://m.salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg?resize=240,300 240w, https://m.salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg?resize=280,350 280w, https://m.salisburypost.com/wp-content/uploads/sites/9/2020/10/Marcus-Anthony-Eudy.jpg?resize=40,50 40w" sizes="(max-width: 240px) 100vw, 240px" /></a><p id="caption-attachment-479923" class="wp-caption-text">Eudy</p></div>
<p>The Rowan County Sheriff&#8217;s Office deputies responded to the home to investigate a suspicious double death. Detectives executed a search warrant at the residence and there were no signs of foul play at the scene. Suspected narcotics and narcotic paraphernalia were located and subsequently sent to the N.C. Crime lab, said Maj. John Sifford.</p>
<div id='mydfpad3' class='ad300x ad'>
                  <div id='div-gpt-ad-bigblock-2'>
                    <script>
                      googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
                    </script>
                  </div>
                  </div><p>Autopsy reports showed both victims died from acute fentanyl poisoning along with other narcotic and alcohol intoxications. The N.C. State crime lab results confirmed that the items collected at the scene contained fentanyl.</p>
<div id='mydfpad4' class='ad'>
                  <div id='div-gpt-ad-instory-third'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-third'); });
                  </script>
                  </div>
                  </div><p>One of the victim&#8217;s phones contained text messages in which there was communication with Eudy about the purchase of narcotics. Search warrants were obtained on all the phones and phone numbers associated with the case, according to a statement.</p>
<p>Last week, a search warrant for Eudy&#8217;s phone number confirmed he was the individual who had communication with the victims during the drug transaction, Sifford said.</p>
<div id='mydfpad2' class='ad300x ad'>
          <div id='div-gpt-ad-bigblock-3'>
            <script>
              googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-3'); });
            </script>
          </div>
          </div><p>Eudy was arrested on Sunday and placed in the Rowan County Detention Center under a $250,000 secured bond. Sifford said more charges are expected.</p>
<p>Anyone with information is asked to call Detective Travis Allen at 704-216-8715, First Sgt. Ollie Greene, First Lt. Rodney Mahaley or Crime Stoppers 1-866-639-5245.</p>

                                              


                      </div>


										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

												

											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>
											</div>



                      <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="112875"></div>
        <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
    

	
<div class="one_by_one_group">
<!-- one_by_one_duration-->
<div id='div-gpt-ad-one_by_one_duration'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_duration'); });
  </script>
</div><div id="rev_video"></div>
</div>



												<div id="disqus_thread"></div>
<h3>Comments</h3>

  <div class="fb-comments" data-href="https://www.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/" data-width="100%" data-numposts="5" data-colorscheme="light"></div>
 


<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
	js.async = true;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.12&appId=168913723140235&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>


									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">
	<li>
		<div class="ad first">
      <div id='div-gpt-ad-bigblock-4'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-4'); });
  </script>
</div>		</div>
	</li>
	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST LOCAL NEWS</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/12/blotter-salisbury-man-faces-drug-charges-after-being-found-unconscious-outside-convenience-store/" title="Permalink to Blotter: Salisbury man faces drug charges after being found unconscious outside convenience store" rel="bookmark">Blotter: Salisbury man faces drug charges after being found unconscious outside convenience store</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/12/photos-look-inside-new-hobbit-house-in-china-grove/" title="Permalink to Photos: Look inside new &#8216;Hobbit House&#8217; in China Grove" rel="bookmark">Photos: Look inside new &#8216;Hobbit House&#8217; in China Grove</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/" title="Permalink to Rowan County man charged in overdose death of Cleveland couple" rel="bookmark">Rowan County man charged in overdose death of Cleveland couple</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/12/police-looking-for-man-who-struck-ambulance-in-hit-run/" title="Permalink to Police looking for man who struck ambulance in hit, run" rel="bookmark">Police looking for man who struck ambulance in hit, run</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/12/after-16-new-covid-19-cases-reported-more-than-460-considered-currently-active/" title="Permalink to After 16 new COVID-19 cases reported, more than 460 considered currently active" rel="bookmark">After 16 new COVID-19 cases reported, more than 460 considered currently active</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		 <div data-cswidget="8627" > </div>
    <script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" > </script>
<iframe src="https://salisburypost.friends2follow.com/f2f/widget/html/socialstack/101/0/12/140/1/1/1/9/9/0" width="300px" height="600px" frameborder="0" scrolling="no"></iframe>
		
<div id="ap_widget_container_ca890116f6b1d98085d4fd61ca134e18"></div>
<script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_13947f0def41fee1d836d75ce3839363" style="overflow: hidden; min-width: 100%; border: none;" src="https://pro32.ap.org/iframe/widgets/content/13947f0def41fee1d836d75ce3839363" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_13947f0def41fee1d836d75ce3839363');"></iframe>
<br />
		<a href="http://salisburypost.nc.newsmemory.com/marketplace.php">
			<img src="//www.salisburypost.com/wp-content/uploads/2016/10/shopping-marketplace-bar-for-web300.jpg" alt="">
		</a>
		<br />
</div></li>
	<li id="polls-widget-2" class="widget widget_polls-widget"><h2 class="widgettitle">Polls</h2>
<div id="polls-88" class="wp-polls">
	<form id="polls_form_88" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_88_nonce" name="wp-polls-nonce" value="ffcb889249" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="88" /></p>
		<p style="text-align: center;"><strong>The Rowan-Salisbury School Board is again planning to hold public hearings and potentially close Faith and Enochville elementary schools. What do you think?</strong></p><div id="polls-88-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-389" name="poll_88" value="389" /> <label for="poll-answer-389">I support closures of both schools.</label></li>
		<li><input type="radio" id="poll-answer-390" name="poll_88" value="390" /> <label for="poll-answer-390">I support the closure of Faith Elementary.</label></li>
		<li><input type="radio" id="poll-answer-391" name="poll_88" value="391" /> <label for="poll-answer-391">I support the closure of Enochville Elementary.</label></li>
		<li><input type="radio" id="poll-answer-392" name="poll_88" value="392" /> <label for="poll-answer-392">I oppose both closures.</label></li>
		<li><input type="radio" id="poll-answer-393" name="poll_88" value="393" /> <label for="poll-answer-393">Indifferent.</label></li>
		</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(88);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(88); return false;" title="View Results Of This Poll">View Results</a></p></div>
	</form>
</div>
<div id="polls-88-loading" class="wp-polls-loading"><img src="https://www.salisburypost.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<ul><li><a href="">Polls Archive</a></li></ul></li>
	<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-5'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-5'); });
  </script>
</div>		</div>
	</li>

  				<li id="recent-posts-2" class="widget widget_recent_entries">		<h2 class="widgettitle">Recent Posts</h2>
		<ul>
											<li>
					<a href="https://m.salisburypost.com/2020/10/12/blotter-salisbury-man-faces-drug-charges-after-being-found-unconscious-outside-convenience-store/">Blotter: Salisbury man faces drug charges after being found unconscious outside convenience store</a>
									</li>
											<li>
					<a href="https://m.salisburypost.com/2020/10/12/photos-look-inside-new-hobbit-house-in-china-grove/">Photos: Look inside new &#8216;Hobbit House&#8217; in China Grove</a>
									</li>
											<li>
					<a href="https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/" aria-current="page">Rowan County man charged in overdose death of Cleveland couple</a>
									</li>
											<li>
					<a href="https://m.salisburypost.com/2020/10/12/police-looking-for-man-who-struck-ambulance-in-hit-run/">Police looking for man who struck ambulance in hit, run</a>
									</li>
											<li>
					<a href="https://m.salisburypost.com/2020/10/12/after-16-new-covid-19-cases-reported-more-than-460-considered-currently-active/">After 16 new COVID-19 cases reported, more than 460 considered currently active</a>
									</li>
					</ul>
		</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST OPINION</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/josh-bergeron-in-lexington-city-county-conflict-springs-up-around-confederate-monument/" title="Permalink to Josh Bergeron: In Lexington, city-county conflict springs up around Confederate monument" rel="bookmark">Josh Bergeron: In Lexington, city-county conflict springs up around Confederate monument</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/darts-and-laurels-livingstones-efforts-in-covid-control-paying-off/" title="Permalink to Darts and Laurels: Livingstone&#8217;s efforts in COVID control paying off" rel="bookmark">Darts and Laurels: Livingstone&#8217;s efforts in COVID control paying off</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/francis-koster-unpolluted-food-for-thought/" title="Permalink to Francis Koster: Unpolluted food for thought" rel="bookmark">Francis Koster: Unpolluted food for thought</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/my-turn-cheryl-goins-poster-draws-unexpected-negative-comments/" title="Permalink to My Turn, Cheryl Goins: Poster draws unexpected, negative comments" rel="bookmark">My Turn, Cheryl Goins: Poster draws unexpected, negative comments</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/my-turn-susan-cox-studer-is-school-board-member-community-needs/" title="Permalink to My Turn, Susan Cox: Studer is school board member community needs" rel="bookmark">My Turn, Susan Cox: Studer is school board member community needs</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_c24754ee9ca7c39e1d5b87941f432e70" style="overflow: hidden; min-width: 100%; border: none;" src="https://racing.ap.org/iframe/widgets/content/c24754ee9ca7c39e1d5b87941f432e70" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_c24754ee9ca7c39e1d5b87941f432e70');"></iframe>		</div></li>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST BUSINESS</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/12/photos-look-inside-new-hobbit-house-in-china-grove/" title="Permalink to Photos: Look inside new &#8216;Hobbit House&#8217; in China Grove" rel="bookmark">Photos: Look inside new &#8216;Hobbit House&#8217; in China Grove</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/biz-roundup-buskers-will-still-get-a-chance-to-shine-during-weekend-showcases/" title="Permalink to Biz Roundup: Buskers will still get a chance to shine during weekend showcases" rel="bookmark">Biz Roundup: Buskers will still get a chance to shine during weekend showcases</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/local-costume-company-readies-for-uncertain-halloween-season/" title="Permalink to Local costume company readies for uncertain Halloween season" rel="bookmark">Local costume company readies for uncertain Halloween season</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/09/economic-development-commission-raises-more-than-1-million-during-campaign/" title="Permalink to Economic Development Commission raises more than $1 million during campaign" rel="bookmark">Economic Development Commission raises more than $1 million during campaign</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/08/local-staffing-agency-looks-to-fill-jobs-quickly-during-hirepalooza/" title="Permalink to Local staffing agency looks to fill jobs quickly during &#8216;HirePalooza&#8217;" rel="bookmark">Local staffing agency looks to fill jobs quickly during &#8216;HirePalooza&#8217;</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
	<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-6'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-6'); });
  </script>
</div>		</div>
	</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-5" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST LIFESTYLE</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/morgan-watts-column-4-h-pullet-project-show-goes-virtual/" title="Permalink to Morgan Watts column: 4-H Pullet Project show goes virtual" rel="bookmark">Morgan Watts column: 4-H Pullet Project show goes virtual</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/mack-williams-column-games-of-chance/" title="Permalink to Mack Williams column: Games of chance" rel="bookmark">Mack Williams column: Games of chance</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/finding-hope-for-the-future-in-childrens-books/" title="Permalink to Finding hope for the future in children’s books" rel="bookmark">Finding hope for the future in children’s books</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/ann-farabee-column-my-covid-journey-part-3-the-room-with-a-door/" title="Permalink to Ann Farabee column: My COVID journey &#8211; Part 3: The room with a door" rel="bookmark">Ann Farabee column: My COVID journey &#8211; Part 3: The room with a door</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2020/10/11/what-is-cholesterol/" title="Permalink to Ester Marsh column: What is cholesterol?" rel="bookmark">Ester Marsh column: What is cholesterol?</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		<a href="http://salisburypost.nc.newsmemory.com/ssindex.php">
			<img src="//www.salisburypost.com/wp-content/uploads/2016/10/special-section-bar-for-web300.jpg" alt="">
		</a>

		<br />
		<br />

		<script language="JavaScript" src="https://salisburypost.mycapture.com/datafeeds/28095.js"></script></div></li>
<li id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_bde00e4c8bdeeb4f1e1ee7efbf372056" style="overflow: hidden; min-width: 100%; border: none;" src="https://racing.ap.org/iframe/widgets/content/bde00e4c8bdeeb4f1e1ee7efbf372056" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_bde00e4c8bdeeb4f1e1ee7efbf372056');"></iframe></div></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  </ul>							</div>

							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/blotter-salisbury-man-faces-drug-charges-after-being-found-unconscious-outside-convenience-store/" rel="bookmark" title="Blotter: Salisbury man faces drug charges after being found unconscious outside convenience store">Blotter: Salisbury man faces drug charges after being found unconscious outside convenience store</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/photos-look-inside-new-hobbit-house-in-china-grove/" rel="bookmark" title="Photos: Look inside new &#8216;Hobbit House&#8217; in China Grove">Photos: Look inside new &#8216;Hobbit House&#8217; in China Grove</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/rowan-county-man-charged-in-overdose-death-of-cleveland-couple/" rel="bookmark" title="Rowan County man charged in overdose death of Cleveland couple">Rowan County man charged in overdose death of Cleveland couple</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/police-looking-for-man-who-struck-ambulance-in-hit-run/" rel="bookmark" title="Police looking for man who struck ambulance in hit, run">Police looking for man who struck ambulance in hit, run</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/after-16-new-covid-19-cases-reported-more-than-460-considered-currently-active/" rel="bookmark" title="After 16 new COVID-19 cases reported, more than 460 considered currently active">After 16 new COVID-19 cases reported, more than 460 considered currently active</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Elections</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/political-notebook-two-local-candidates-drop-out-of-rowan-chamber-of-commerce-forum/" rel="bookmark" title="Political Notebook: Two local candidates drop out of Rowan Chamber of Commerce forum">Political Notebook: Two local candidates drop out of Rowan Chamber of Commerce forum</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Ask Us</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/ask-us-whats-causing-noise-near-train-tracks-in-salisbury-spencer-area/" rel="bookmark" title="Ask Us: What&#8217;s causing noise near train tracks in Salisbury, Spencer area?">Ask Us: What&#8217;s causing noise near train tracks in Salisbury, Spencer area?</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/blotter-man-charged-after-two-die-from-fentanyl-in-illegal-narcotics-he-provided/" rel="bookmark" title="Blotter: Man charged after deaths from fentanyl he&#8217;s accused of providing">Blotter: Man charged after deaths from fentanyl he&#8217;s accused of providing</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/senators-weigh-covid-risk-for-barrett-supreme-court-hearing/" rel="bookmark" title="Senators weigh COVID risk for Barrett Supreme Court hearing">Senators weigh COVID risk for Barrett Supreme Court hearing</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/12/we-cant-lose-our-momentum-louisiana-vows-to-rebuild/" rel="bookmark" title="&#8216;We can&#8217;t lose our momentum:&#8217; Louisiana vows to rebuild">&#8216;We can&#8217;t lose our momentum:&#8217; Louisiana vows to rebuild</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Elections</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/early-voting-begins-thursday-heres-what-local-voters-need-to-know/" rel="bookmark" title="Early voting begins Thursday; here&#8217;s what local voters need to know">Early voting begins Thursday; here&#8217;s what local voters need to know</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/millers-ferry-crash-prompts-policies-to-protect-first-responders/" rel="bookmark" title="Miller&#8217;s Ferry crash prompts policies to protect first responders">Miller&#8217;s Ferry crash prompts policies to protect first responders</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/biz-roundup-buskers-will-still-get-a-chance-to-shine-during-weekend-showcases/" rel="bookmark" title="Biz Roundup: Buskers will still get a chance to shine during weekend showcases">Biz Roundup: Buskers will still get a chance to shine during weekend showcases</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/school-board-to-receive-update-on-bringing-elementary-students-back-full-time/" rel="bookmark" title="School board to receive update on bringing elementary students back full time">School board to receive update on bringing elementary students back full time</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/gotta-run-runners-and-everybody-else-need-vitamin-d/" rel="bookmark" title="Gotta Run: Runners and everybody else need vitamin D">Gotta Run: Runners and everybody else need vitamin D</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/resino-returns-to-elder-care-from-child-care-maternity-leave/" rel="bookmark" title="Resino returns to elder care from child care, maternity leave">Resino returns to elder care from child care, maternity leave</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/more-than-6500-visits-to-seven-local-historic-sites-during-first-virtual-octobertour/" rel="bookmark" title="First virtual OctoberTour brought more than 6,500 pageviews by Saturday">First virtual OctoberTour brought more than 6,500 pageviews by Saturday</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Lifestyle</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/bible-teaching-ministry-schedules-golf-tournament-for-oct-26/" rel="bookmark" title="Bible teaching ministry schedules golf tournament for Oct. 26">Bible teaching ministry schedules golf tournament for Oct. 26</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News Main</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/football-parks-helps-youngsters-stay-active-during-covid-19/" rel="bookmark" title="Football: Parks helps youngsters stay active during COVID-19">Football: Parks helps youngsters stay active during COVID-19</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/local-costume-company-readies-for-uncertain-halloween-season/" rel="bookmark" title="Local costume company readies for uncertain Halloween season">Local costume company readies for uncertain Halloween season</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/rotary-club-gives-free-shoes-to-every-third-grader-in-rss/" rel="bookmark" title="Rotary Club gives free shoes to every third grader in RSS">Rotary Club gives free shoes to every third grader in RSS</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/state-funded-pre-k-seats-still-open-in-rowan-county/" rel="bookmark" title="State-funded pre-K seats still open in Rowan County">State-funded pre-K seats still open in Rowan County</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/emergency-responder-safety-institute-tracks-roadside-collision-data/" rel="bookmark" title="Emergency Responder Safety Institute tracks roadside collision data">Emergency Responder Safety Institute tracks roadside collision data</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Lifestyle</h4>
											<h3><a href="https://m.salisburypost.com/2020/10/11/an-even-larger-trove-of-treasures-awaits-at-this-years-cystic-fibrosis-yard-sale/" rel="bookmark" title="An even larger trove of treasures awaits at this year&#8217;s cystic fibrosis yard sale">An even larger trove of treasures awaits at this year&#8217;s cystic fibrosis yard sale</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

						<div class="clearfix"></div>
					</div>
					<div id="footer" class="clearfix">

						<div id="footSections" class="col">
							
							<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://m.salisburypost.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://m.salisburypost.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://m.salisburypost.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://m.salisburypost.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://m.salisburypost.com/category/lifestyle/" title="" rel="bookmark"><span>Lifestyle</span></a></li>
								<li><a href="https://m.salisburypost.com/category/health/" title="" rel="bookmark"><span>Health</span></a></li>
								<li><a href="https://m.salisburypost.com/category/faith/" title="" rel="bookmark"><span>Faith</span></a></li>
								<li><a href="http://www.legacy.com/obituaries/salisburypost/" title="" rel="bookmark"><span>Obituaries</span></a></li>
								<li><a href="http://marketplace.salisburypost.com/adhunter/SalisburyPost/" title="" rel="bookmark"><span>Classifieds</span></a></li>
								<li><a href="http://video.salisburypost.com/" title="" rel="bookmark"><span>Video</span></a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
							
							<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://m.salisburypost.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
								<li><a href="https://m.salisburypost.com/customer-service/" title="" rel="bookmark">Contact Us</a></li>
								<li><a href="http://www.salisburypost.com/subscriptions/" title="" rel="nofollow">Subscribe</a></li>
								<li><a href="https://m.salisburypost.com/services/policies/" title="" rel="bookmark">Policies</a></li>
								<li><a href="https://m.salisburypost.com/services/policies/" title="" rel="nofollow">Terms of use</a></li>
								<li><a href="https://m.salisburypost.com/services/submit-a-news-tip/" title="" rel="nofollow">Submit a news tip</a></li>
								<li><a href="https://m.salisburypost.com/customer-service/" title="" rel="nofollow">Online Forms</a></li>
								<li><a href="https://m.salisburypost.com/editorial-social/" title="" rel="nofollow">Social Media</a></li>
								<li><a href="http://salisburypostnie.com/" title="" rel="nofollow">NIE - Newspapers In Education</a></li>
								<li><a href="http://salisburypost.mycapture.com/mycapture/index.asp" title="" rel="bookmark"><span>Purchase Photos</span></a></li>
				
								
															</ol>
						</div>


						<div id="footCopyright" class="col">
							


							<h4>Copyright</h4>
							<ol>
								<li>&copy; 2020, Salisbury Post</li>
							</ol>
						</div>

					</div>
				</div>

        <div id="mobile_footer_ad">
					<div class="ad">
						<!-- 320x50_mobile_sticky -->
<div id='div-gpt-ad-mobile-sticky'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-sticky'); });
  </script>
</div>					</div>
				</div>

				</div>

				<div class="sb-slidebar sb-left">
					<!-- Your left Slidebar content. -->
					<ul id="slidebarList">
					</ul>
				</div>


								<script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.js?1599406936"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.timeago.js"></script>
				<script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/readmore.min.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/plugins.js?1599406936"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/main.js?1599406936"></script>

        

	
				
<script type="text/javascript">tb_pathToImage = "https://m.salisburypost.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://m.salisburypost.com/wp-includes/js/thickbox/tb-close.png";</script>
<script>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/m.salisburypost.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://m.salisburypost.com/wp-includes/js/thickbox/thickbox.js?m=1598593033g'></script>
<script src='https://www.salisburypost.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.6'></script>
<script>
var pollsL10n = {"ajax_url":"https:\/\/m.salisburypost.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script src='https://www.salisburypost.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3'></script>
<script type='text/javascript' src='https://m.salisburypost.com/wp-includes/js/wp-embed.min.js?m=1598593034g'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202042.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'170543381',post:'479898',tz:'-4',srv:'m.salisburypost.com'} ]);
	_stq.push([ 'clickTrackerInit', '170543381', '479898' ]);
</script>
				</div><!-- END undertone -->
            </body>
</html>