<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lato:300,400,900,900italic,300italic,400italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>High school football: Falcons 2-0 in NPC - Salisbury Post | Salisbury Post</title>

                <meta name="viewport" content="width=device-width, initial-scale=1">

				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.min.css?1599406936" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1599406936" />
				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/css/normalize.css?1599406936" />
				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/css/base.css?1599406936" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/style.css?1599406936" />

        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/modernizr-2.6.2.min.js?1599406936"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.salisburypost.com/wp-content/themes/2016-salisbury-mobile-child/media/img/brand/favicon-salisburypost.png">
				<link rel="apple-touch-icon" href="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/images/brand/apple-touch-icon.png" />

				
																<meta name='robots' content='max-image-preview:large' />

	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="High school football: Falcons 2-0 in NPC - Salisbury Post" />
	<meta property="og:description" content="Staff report TROUTMAN — A wise man once said that there are no bad road wins. West Rowan survived more than thrived on Friday, but the Falcons outlasted South Iredell 20-14 to move to 2-0 in the North Piedmont Conference. &#8220;Really physical game,&#8221; West head coach Louis Kraft said. &#8220;I thought we played with maximum [&hellip;]" />
	<meta property="og:url" content="https://salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/" />
	<meta property="og:site_name" content="Salisbury Post" />
	<meta property="article:published_time" content="2021-03-20T11:02:19+00:00" />
	<meta property="article:modified_time" content="2021-03-20T11:02:33+00:00" />
	<meta property="og:image" content="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/01/facebook-salisburypost.png" />
	<meta property="og:image:width" content="398" />
	<meta property="og:image:height" content="208" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Post Sports">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="1 minute">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.salisburypost.com/#website","url":"https://www.salisburypost.com/","name":"Salisbury Post","description":"News from Salisbury, North Carolina","potentialAction":[{"@type":"SearchAction","target":"https://www.salisburypost.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/#primaryimage","inLanguage":"en-US","url":"https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg","width":6096,"height":4760},{"@type":"WebPage","@id":"https://salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/#webpage","url":"https://salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/","name":"High school football: Falcons 2-0 in NPC - Salisbury Post","isPartOf":{"@id":"https://www.salisburypost.com/#website"},"primaryImageOfPage":{"@id":"https://salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/#primaryimage"},"datePublished":"2021-03-20T11:02:19+00:00","dateModified":"2021-03-20T11:02:33+00:00","author":{"@id":"https://www.salisburypost.com/#/schema/person/514e6c6e9a9496983d1e473b54b8b115"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/"]}]},{"@type":"Person","@id":"https://www.salisburypost.com/#/schema/person/514e6c6e9a9496983d1e473b54b8b115","name":"Post Sports","image":{"@type":"ImageObject","@id":"https://www.salisburypost.com/#personlogo","inLanguage":"en-US","url":"https://m.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?w=54","caption":"Post Sports"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.salisburypost.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Salisbury Post &raquo; High school football: Falcons 2-0 in NPC Comments Feed" href="https://m.salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/m.salisburypost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://m.salisburypost.com/_static/??-eJxljFEOQDAQBS9EV4n+ibPokljdtmIruD2REIm/l3mTgW3OKSCv/SCAItB3MhLGIMpTUBfJ4KtMAun6nY37O/7WHSJJYDmiy5ns0i0HSDp4eLqtb7TRdVVqUxQnboEw7g==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.salisburypost.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.6' media='all' />
<link rel='stylesheet' id='m1mw-css'  href='https://www.salisburypost.com/wp-content/plugins/m1miniweather-bni-.0.2.b/css/weather-icons.min.css?ver=5.7' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://m.salisburypost.com/wp-includes/css/admin-bar.min.css?m=1615321600g' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<link rel='stylesheet' id='wp-polls-css'  href='https://www.salisburypost.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' media='all' />
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.salisburypost.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.salisburypost.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/style.css?ver=5.7' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://www.salisburypost.com/wp-content/themes/2016-salisbury-mobile-child/style.css?ver=1614897126' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.salisburypost.com/wp-content/mu-plugins/jetpack-9.5/css/jetpack.css?ver=9.5.2' media='all' />
<script type='text/javascript' src='https://m.salisburypost.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZoamxkaGZgUEWAK8vIhE='></script>
<link rel="https://api.w.org/" href="https://m.salisburypost.com/wp-json/" /><link rel="alternate" type="application/json" href="https://m.salisburypost.com/wp-json/wp/v2/posts/500823" /><link rel='shortlink' href='https://m.salisburypost.com/?p=500823' />
<link rel="alternate" type="application/json+oembed" href="https://m.salisburypost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.salisburypost.com%2F2021%2F03%2F20%2Fhigh-school-football-falcons-2-0-in-npc%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://m.salisburypost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.salisburypost.com%2F2021%2F03%2F20%2Fhigh-school-football-falcons-2-0-in-npc%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style><!-- Global site tag (gtag.js) - Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-34177675-1', 'auto');
  ga('send', 'pageview');
</script>
											<script type="text/javascript">
					document.write(unescape("%3Cscript src='https://subscriptions.salisburypost.com/bwtw/scripts/tw.js' type='text/javascript'%3E%3C/script%3E"));
				</script>
				<script type="text/javascript">

          _bwtp = new TheWall('https://subscriptions.salisburypost.com/bwtw/', 'SP', 'SP', null, 'DEFAULT');

          var pw_total_val = '0';
          var pw_read_val = '0';

					_bwtp.init();
          loggedin = _bwtp.userStatus();
          _bwtp.status(function(f) { 
            pw_total_val = f.viewRate.AllowedViews;
            pw_read_val = f.viewRate.NumViews;
          });

					jQuery(window).load(function() { // These functions get called when everything has loaded
						if (!loggedin) {
							jQuery("#slidebarList").prepend('<li><a href="#" onclick="_bwtp.Auth(true);">Log In</a></li>');
              if (( pw_total_val > 0 ) && ( pw_read_val <= pw_total_val ) && ( jQuery('body').attr("id") != "homePage")) {
                var paywall_info_content = '<div id="paywall_info_box" style="padding: 1em 0; margin: 1em 0; font-weight: bold; border-top: 1px solid #aaa; border-bottom: 1px solid #aaa; text-align: center; color: #222;">' +
                  '<p style="font-weight: bold;">You have read ' + pw_read_val + ' of ' + pw_total_val + ' articles.</p>' +
                  '<p style="margin-bottom: 0; font-weight: bold;"><a href="#" onclick="_bwtp.Auth(true);" style="color: #92191f;">Log In or Subscribe</a></p>' + 
                  '</div>';
                jQuery(paywall_info_content).appendTo('div#article div.byline').fadeIn();
              }

						} else {
							jQuery("#slidebarList").prepend('<li><a href="#" onclick="_bwtp.clearID();">Log Out</a></li>');
						}
					});
				</script>


				<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>



    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>

googletag.cmd.push(function() {
    			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/SNL-m-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/SNL-m-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }
    

			googletag.defineSlot('/1613683/SNL-m-320x50-1', [320, 50], 'div-gpt-ad-mobile-leader').addService(googletag.pubads());
			BIGBLOCK_AD_ONE = googletag.defineSlot('/1613683/SNL-m-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			BIGBLOCK_AD_TWO = googletag.defineSlot('/1613683/SNL-m-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			BIGBLOCK_AD_THREE = googletag.defineSlot('/1613683/SNL-m-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-6', [300, 250], 'div-gpt-ad-bigblock-6').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());
  if (!loggedin) {
			googletag.defineOutOfPageSlot('/1613683/SNL-m-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-m-320x50-sticky', [[320, 50], [1, 1]], 'div-gpt-ad-mobile-sticky').addService(googletag.pubads());
  }

                  googletag.pubads().setTargeting("catname", [ "high-school", "sports",  ]);
          
          googletag.pubads().setTargeting("pageurl", "/2021/03/20/high-school-football-falcons");
    
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });

		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
		googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/SNL-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/SNL-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/SNL-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/SNL-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/SNL-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/SNL-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/SNL-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/SNL-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/SNL-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/SNL-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/SNL-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/SNL-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/SNL-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/SNL-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/SNL-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/SNL-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/SNL-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/SNL-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/SNL-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/SNL-320x50-1',
          sizes: [[320, 50], [1, 1]]
      }
     ],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


<script>
   var otkjs = otkjs || {};
    /**
     * Add any divs to refresh.
     * 
     * Parameters:
     * 1. Array of divs w/parameter to refresh, can be one or many:
     *  - DIV_ID: The DOM div id of the ad position
     *  - MIN_TIME_IN_VIEW: The amount of time the ad must be 
     *      in view before being eligible to be refreshed, we recommend at least 1.1 seconds
     *  - MIN_TIME_ON_PAGE: The amount of time the ad must be in von the page before refreshing 
     *  - TARGETING: Array of key/value targeting for the ad slot.
     * 
     * NOTE: The ad will on refresh once the parameters are met and the ad is
     * is currently in view.
     * 
     * Function:
     * otkjs.addRefresh(
     * Array[
     *    Array[DIV_ID, MIN_TIME_IN_VIEW, MIN_TIME_ON_PAGE, TARGETING[Array['key', 'value']]
     * ]);
     * 
     * Example - add two ad divs to be refreshed:
     *   otkjs.addRefresh([
     *     ['div-1', 1.1, 30, [['key2', 'value2'], ['refresh', 'true']]],
     *     ['div-2', 1.1, 30, [['key4', 'value4'], ['refresh', 'true']]]
     *   ]);
     */
      var mt_in_view = 1.2
      var mt_on_page = 34

      otkjs.addRefresh([
        //['div-1', mt_in_view, mt_on_page, [['refresh', 'true']]]
        ['div-gpt-ad-extra_one_by_one', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_oop', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one_two', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-leader', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-2', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-3', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-4', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-5', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-6', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-halfpage-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-screenshift', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-sticky', mt_in_view, mt_on_page, [['refresh', 'true']]],
      ]);
  </script>
        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/qgm--t1cSnkJXHwvoo7JKXT4-fniaL7GoKdYaAHjVpaT3LGQD-2yOxsw17xqTxCsa1eU6UZ1N43JR0",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>


<meta property="fb:app_id" content="168913723140235" />

                        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
        
    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
        																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://m.salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_acby66y5aly33aqou3rkicnpnu'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div class="undertone">

				<div class="mobile-nav sb-slide">
									<div class="sb-toggle-left navbar-left">
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
					</div><!-- /.sb-control-left -->
					<a href="https://m.salisburypost.com">
						<img class="logo" src="https://www.salisburypost.com/wp-content/themes/2016-salisbury-mobile-child/media/img/brand/logo-white-salisburypost.png" alt="Salisbury Post" />
					</a>
					<div class="search">
						<a href="#" class="expand">expand</a>
						<form method="get" class="searchForm" action="https://m.salisburypost.com/site-search">
							<input type="submit" class="searchButton" value="Go" />
							<input type="text" name="q" class="searchQuery" value="Search Salisbury Post..." onfocus="if(this.value=='Search Salisbury Post...'){this.value='';}" onblur="if(this.value==''){this.value='Search Salisbury Post...';}" />
						</form>
					</div>
				</div>

				<div id="sb-site">
					<!-- Add your site or application content here -->
					<div class="upper_ad">
						<div class="wrapper">
							<div class="ad">
								<div class="ad720x90">Ad Spot</div>
							</div>
						</div>
					</div>
					<div class="sup_nav">
						<div class="wrapper">
														<p class="date">
								March 20, 2021							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div class="wrapper">
						<header>
							<nav id="navbar">
								<ul id="mainNav">
	<li class="public_notices"><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=2600">Public Notices</a></li>
	<li class=""><a href="https://subscriptions.salisburypost.com/CircStore/Account/Login?vendor=DirXion&prodId=SP">E-edition</a></li>
  <li><a href="https://m.salisburypost.com/customer-service/">Submit</a></li>
  <li><a href="https://m.salisburypost.com/category/news/local/" title="Local News | Salisbury, North Carolina - The Salisbury Post">Local</a></li>
	<li class="subscribe"><a href="http://www.salisburypost.com/subscriptions/">Subscriptions</a></li>
	<li class="classifieds"> <a href="https://marketplace.salisburypost.com/adhunter/SalisburyPost/">Classifieds</a> </li>
  <li><a href="https://m.salisburypost.com/category/business/" title="Business News | Salisbury, North Carolina - The Salisbury Post">Business</a></li>
  <li><a href="https://m.salisburypost.com/category/news/politics/" title="Politics | Salisbury, North Carolina - The Salisbury Post">Politics</a></li>
  <li><a href="https://m.salisburypost.com/category/crime/" title="Crime | Salisbury, North Carolina - The Salisbury Post">Crime</a></li>
  <li><a href="https://m.salisburypost.com/category/news/kannapolis/" title="Kannapolis News | Salisbury, North Carolina - The Salisbury Post">Kannapolis</a></li>
  <li><a href="https://m.salisburypost.com/category/opinion/" title="Opinion | Salisbury, North Carolina - The Salisbury Post">Opinion</a></li>
	<li class="sports"> <a href="https://m.salisburypost.com/category/sports/">Sports</a> </li>
  <li><a href="https://m.salisburypost.com/category/sports/high-school/" title="High School Sports | Salisbury, North Carolina - The Salisbury Post">High School</a></li>
	<li class="lifestyle"> <a href="https://m.salisburypost.com/category/lifestyle/">Life</a> </li>
	<li class="obituaries"><a href="http://www.legacy.com/obituaries/salisburypost/">Obits</a></li>
	<li class=""><a href="http://salisburypost.nc.newsmemory.com/ssindex.php">Special Sections</a></li>
  <li class=""><a href="http://salisburypost.mycapture.com/mycapture/index.asp">Photos</a></li>
	<li class=""><a href="http://www.salisburythemagazine.com/">SALISBURY the Magazine</a></li>
  <li class="RoCo Gold"><a href="http://www.rocogold.com">RoCo Gold Awards</a></li>  
  <li><a href="https://m.salisburypost.com/category/spirit-of-rowan/">Spirit of Rowan</a></li>
  <li><a href="https://m.salisburypost.com/customer-service/">Contact Us</a></li>
  <li><a href="https://marketplace.salisburypost.com/Salisbury/">Place an Ad</a></li>

	<li class="fun "><a href="https://m.salisburypost.com/fun/">Fun</a></li>

		
</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content">
							<div id="notifications">
								






								


								
								
							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  </script>
</div>	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  </script>
</div></div>

	
							<div class="ad first">
								<!-- 320x50_mobile_leader -->
<div id='div-gpt-ad-mobile-leader'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-leader'); });
  </script>
</div>							</div>



							<div class="main_column">
								<div class="story">
									
									
                      <div class="prev_next_article">
  <!-- v 1.61 -->
          <div class="prev_article">
        <div class="padding">
          <a href="https://m.salisburypost.com/2021/03/20/high-school-football-wonders-romp/" class="arrow left button">
            <svg width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            45.63,75.8 0.375,38.087 45.63,0.375 "/>
            </svg>  
          </a>
        </div>
      </div>
    
                              <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <div class="thumb">
            <a href="https://m.salisburypost.com/2021/03/20/high-school-football-wonders-romp/">
              <img src="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-sports.jpg?w=90&h=90&crop=1" alt="" width="50" height="50">
            </a>
          </div>
                    <h4> <a href="https://m.salisburypost.com/2021/03/20/high-school-football-wonders-romp/">High school football: Wonders romp</a> </h4>
          <a href="https://m.salisburypost.com/2021/03/20/high-school-football-wonders-romp/" class="arrow right button">
            <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            0.375,0.375 45.63,38.087 0.375,75.8 "/>
            </svg>
          </a>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    <dl class='story_photo_item'><dt><img width="622" height="486" src="https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?w=622" class="attachment-story-photo size-story-photo wp-post-image" alt="" loading="lazy" srcset="https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg 6096w, https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?resize=300,234 300w, https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?resize=768,600 768w, https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?resize=1024,800 1024w, https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?resize=1536,1199 1536w, https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?resize=2048,1599 2048w, https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?resize=622,486 622w, https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?resize=448,350 448w" sizes="(max-width: 622px) 100vw, 622px" /></dt><dd class='wp-caption-text'></dd></dl>

              </div>
    </div>
		
									<div id="leftRail" class="">
																			</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>High school football: Falcons 2-0 in NPC</h2>

										<div class="byline">
											
											<a href="https://m.salisburypost.com/author/post.sports/" rel="bookmark">
                        <img width="67" height="120" src="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?w=67" class="avatar avatar-120 photo" alt="" loading="lazy" srcset="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg 200w, https://m.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?resize=168,300 168w, https://m.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?resize=196,350 196w" sizes="(max-width: 67px) 100vw, 67px" />											</a>

											<p class="author">
												<strong>By <a href="https://m.salisburypost.com/author/post.sports/" rel="bookmark">Post Sports</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:sports@salisburypost.com">Email the author</a>
																							</p>
											<p class="pubStamp">Published 7:02 am Saturday, March 20, 2021</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  </script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  </script>
</div>                    </div>

										<div class="p402_premium">


										
										<div class="story_detail">
                      <div class="read_more_wrap">
                        
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>var TRINITY_TTS_WP_CONFIG = {"cleanText":"High school football: Falcons 2-0 in NPC. Staff report\r\n\r\nTROUTMAN \u2014 A wise man once said that there are no bad road wins.\r\n\r\nWest Rowan survived more than thrived on Friday, but the Falcons outlasted South Iredell 20-14 to move to 2-0 in the North Piedmont Conference.\r\n\r\n\"Really physical game,\" West head coach Louis Kraft said. \"I thought we played with maximum effort. That's what we preach and that's what got us out of there with the win.\"\r\n\r\nThe Falcons (2-2 overall) have come back nicely from lopsided losses to Salisbury and Davie that opened the season.\r\n\r\nWest is tied with Statesville for first place. Carson can also get to 2-0 if it can beat East Rowan in a Saturday noon game that will be played at A.L. Brown.\r\n\r\nSouth Iredell (1-3, 0-2) is pretty much out of the league race already, but will try to spoil the dreams of some other squads.\r\n\r\nThe first half\u00a0 belonged to the Falcons.\r\n\r\nCayleb Brawley scored on a 6-yard run for the lead.\r\n\r\nIt was 14-0 after Noah Loeblein threw a touchdown pass to Damon Phillippe that covered 40-plus yards.\r\n\r\nThat was the score at halftime.\r\n\r\n\"Then in the second half, it was like South Iredell had the ball the entire half\" Kraft said, \"They were shoving it to us pretty good.\"\r\n\r\nWhen the Vikings scored late in the third quarter to make it 14-7, Hunter Watts ran back the kickoff about 90 yards for a West touchdown.\r\n\r\nThat was great news \u2014 a 20-7 lead. But the downside was West's defense headed right back onto the field.\r\n\r\nSouth Iredell made it 20-14 with about 10 minutes to go, but the Falcons made the stops and finished off the victory.\r\n\r\n\"Our defensive guys, I know they're just dog-tired right now,\" Kraft said. \"But they didn't break.\"","pluginVersion":"2.4.0"};</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=677143c5c1f3a1a2fcc0862c5951f602&postHash=dc3bb52fb9f14df4868e4c2a4168859d&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><p>Staff report</p>
<p>TROUTMAN — A wise man once said that there are no bad road wins.</p>
<p>West Rowan survived more than thrived on Friday, but the Falcons outlasted South Iredell 20-14 to move to 2-0 in the North Piedmont Conference.</p>
<div id='mydfpad' class='ad300x ad'>
            <div id='div-gpt-ad-bigblock-1'>
              <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-1'); });
              </script>
            </div>
          </div>
          <div id='cedato-unit'></div><p>&#8220;Really physical game,&#8221; West head coach Louis Kraft said. &#8220;I thought we played with maximum effort. That&#8217;s what we preach and that&#8217;s what got us out of there with the win.&#8221;</p>
<p>The Falcons (2-2 overall) have come back nicely from lopsided losses to Salisbury and Davie that opened the season.</p>
<p>West is tied with Statesville for first place. Carson can also get to 2-0 if it can beat East Rowan in a Saturday noon game that will be played at A.L. Brown.</p>
<div id='mydfpad3' class='ad300x ad'>
                  <div id='div-gpt-ad-bigblock-2'>
                    <script>
                      googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
                    </script>
                  </div>
                  </div><p>South Iredell (1-3, 0-2) is pretty much out of the league race already, but will try to spoil the dreams of some other squads.</p>
<p>The first half  belonged to the Falcons.</p>
<p>Cayleb Brawley scored on a 6-yard run for the lead.</p>
<div id='mydfpad4' class='ad'>
                  <div id='div-gpt-ad-instory-third'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-third'); });
                  </script>
                  </div>
                  </div><p>It was 14-0 after Noah Loeblein threw a touchdown pass to Damon Phillippe that covered 40-plus yards.</p>
<p>That was the score at halftime.</p>
<p>&#8220;Then in the second half, it was like South Iredell had the ball the entire half&#8221; Kraft said, &#8220;They were shoving it to us pretty good.&#8221;</p>
<div id='mydfpad2' class='ad300x ad'>
          <div id='div-gpt-ad-bigblock-3'>
            <script>
              googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-3'); });
            </script>
          </div>
          </div><p>When the Vikings scored late in the third quarter to make it 14-7, Hunter Watts ran back the kickoff about 90 yards for a West touchdown.</p>
<p>That was great news — a 20-7 lead. But the downside was West&#8217;s defense headed right back onto the field.</p>
<p>South Iredell made it 20-14 with about 10 minutes to go, but the Falcons made the stops and finished off the victory.</p>
<p>&#8220;Our defensive guys, I know they&#8217;re just dog-tired right now,&#8221; Kraft said. &#8220;But they didn&#8217;t break.&#8221;</p>

                                              


                      </div>


										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

												

											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>
											</div>

	              
<div class="more_to_explore">
  <h4>More News</h4>

  
        <div class="story">
                    <a href="https://m.salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.salisburypost.com/wp-content/uploads/sites/9/2021/03/West.East-Football-WH-30.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="High school football: Falcons 2-0 in NPC">High school football: Falcons 2-0 in NPC</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://m.salisburypost.com/2021/03/20/high-school-football-wonders-romp/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-sports.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.salisburypost.com/2021/03/20/high-school-football-wonders-romp/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="High school football: Wonders romp">High school football: Wonders romp</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://m.salisburypost.com/2021/03/20/high-school-football-cavaliers-bounce-back/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-sports.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.salisburypost.com/2021/03/20/high-school-football-cavaliers-bounce-back/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="High school football: Cavaliers bounce back">High school football: Cavaliers bounce back</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://m.salisburypost.com/2021/03/20/high-school-football-raiders-make-up-for-early-struggles/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-sports.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.salisburypost.com/2021/03/20/high-school-football-raiders-make-up-for-early-struggles/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="High school football: Raiders make up for early struggles">High school football: Raiders make up for early struggles</a></h3>

          <div class="clearfix"></div>
        </div>

        
</div>
        <ul class="sidebar">
                    </ul>
	

                      <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="112875"></div>
        <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
    

	
<div class="one_by_one_group">
<!-- one_by_one_duration-->
<div id='div-gpt-ad-one_by_one_duration'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_duration'); });
  </script>
</div><div id="rev_video"></div>
</div>



												<div id="disqus_thread"></div>
<h3>Comments</h3>

  <div class="fb-comments" data-href="https://www.salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/" data-width="100%" data-numposts="5" data-colorscheme="light"></div>
 


<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
	js.async = true;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.12&appId=168913723140235&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>


									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">
	<li>
		<div class="ad first">
      <div id='div-gpt-ad-bigblock-4'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-4'); });
  </script>
</div>		</div>
	</li>
	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST LOCAL NEWS</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/20/city-to-fill-abandoned-sewer-pipe-under-city-park-lake-after-leak/" title="Permalink to City to fill abandoned sewer pipe under City Park Lake after leak" rel="bookmark">City to fill abandoned sewer pipe under City Park Lake after leak</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/19/nc-federal-attorneys-24-more-charged-in-voter-fraud-probe/" title="Permalink to NC federal attorneys: 24 more charged in voter-fraud probe" rel="bookmark">NC federal attorneys: 24 more charged in voter-fraud probe</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/19/nc-resident-among-four-proud-boys-charged-in-plot-to-attack-capitol/" title="Permalink to NC resident among four Proud Boys charged in plot to attack Capitol" rel="bookmark">NC resident among four Proud Boys charged in plot to attack Capitol</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/19/more-than-3000-rowan-residents-received-vaccination-this-week/" title="Permalink to More than 3,000 Rowan residents received vaccination this week" rel="bookmark">More than 3,000 Rowan residents received vaccination this week</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/19/pipe-replacement-requires-road-closure-in-eastern-rowan/" title="Permalink to Pipe replacement requires road closure in eastern Rowan" rel="bookmark">Pipe replacement requires road closure in eastern Rowan</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		 <div data-cswidget="8627" > </div>
    <script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" > </script>
<br>
<iframe src="https://salisburypost.friends2follow.com/f2f/widget/html/postfeed2/101/0/12/140/1/1/1/9/9/1" width="300px" height="550px" frameborder="0" scrolling="no"></iframe>
<br>		
<div data-cswidget="L1007"> </div>
<script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" > </script>

<div id="ap_widget_container_ca890116f6b1d98085d4fd61ca134e18"></div>
<script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_13947f0def41fee1d836d75ce3839363" style="overflow: hidden; min-width: 100%; border: none;" src="https://pro32.ap.org/iframe/widgets/content/13947f0def41fee1d836d75ce3839363" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_13947f0def41fee1d836d75ce3839363');"></iframe>
<br />
		<a href="http://salisburypost.nc.newsmemory.com/marketplace.php">
			<img src="//www.salisburypost.com/wp-content/uploads/2016/10/shopping-marketplace-bar-for-web300.jpg" alt="">
		</a>
		<br />
</div></li>
	<li id="polls-widget-2" class="widget widget_polls-widget"><h2 class="widgettitle">Polls</h2>
<div id="polls-101" class="wp-polls">
	<form id="polls_form_101" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_101_nonce" name="wp-polls-nonce" value="2d416ce83d" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="101" /></p>
		<p style="text-align: center;"><strong>How do you plan to spend the third stimulus check from the federal government</strong></p><div id="polls-101-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-448" name="poll_101" value="448" /> <label for="poll-answer-448">Pay bills</label></li>
		<li><input type="radio" id="poll-answer-449" name="poll_101" value="449" /> <label for="poll-answer-449">Buy things for myself or family members</label></li>
		<li><input type="radio" id="poll-answer-450" name="poll_101" value="450" /> <label for="poll-answer-450">Save it</label></li>
		<li><input type="radio" id="poll-answer-451" name="poll_101" value="451" /> <label for="poll-answer-451">Donate it to charity</label></li>
		<li><input type="radio" id="poll-answer-452" name="poll_101" value="452" /> <label for="poll-answer-452">I'm not eligible to receive a check</label></li>
		</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(101);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(101); return false;" title="View Results Of This Poll">View Results</a></p></div>
	</form>
</div>
<div id="polls-101-loading" class="wp-polls-loading"><img src="https://www.salisburypost.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<ul><li><a href="">Polls Archive</a></li></ul></li>
	<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-5'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-5'); });
  </script>
</div>		</div>
	</li>

  		
		<li id="recent-posts-2" class="widget widget_recent_entries">
		<h2 class="widgettitle">Recent Posts</h2>

		<ul>
											<li>
					<a href="https://m.salisburypost.com/2021/03/20/high-school-football-falcons-2-0-in-npc/" aria-current="page">High school football: Falcons 2-0 in NPC</a>
									</li>
											<li>
					<a href="https://m.salisburypost.com/2021/03/20/high-school-football-wonders-romp/">High school football: Wonders romp</a>
									</li>
											<li>
					<a href="https://m.salisburypost.com/2021/03/20/high-school-football-cavaliers-bounce-back/">High school football: Cavaliers bounce back</a>
									</li>
											<li>
					<a href="https://m.salisburypost.com/2021/03/20/high-school-football-raiders-make-up-for-early-struggles/">High school football: Raiders make up for early struggles</a>
									</li>
											<li>
					<a href="https://m.salisburypost.com/2021/03/20/city-to-fill-abandoned-sewer-pipe-under-city-park-lake-after-leak/">City to fill abandoned sewer pipe under City Park Lake after leak</a>
									</li>
					</ul>

		</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST OPINION</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/18/editorial-will-k-9-incident-be-like-viral-rockwell-case/" title="Permalink to Editorial: Will K-9 incident be like viral Rockwell case?" rel="bookmark">Editorial: Will K-9 incident be like viral Rockwell case?</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/18/sharon-randall-how-to-say-i-remember-you/" title="Permalink to Sharon Randall: How to say &#8216;I remember you&#8217;" rel="bookmark">Sharon Randall: How to say &#8216;I remember you&#8217;</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/17/gary-pearce-tracking-north-carolinas-blue-shift/" title="Permalink to Gary Pearce: Tracking North Carolina’s &#8216;Blue Shift’" rel="bookmark">Gary Pearce: Tracking North Carolina’s &#8216;Blue Shift’</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/17/other-voices-be-smart-with-the-relaxing-of-covid-19-restrictions/" title="Permalink to Other Voices: Be smart with the relaxing of COVID-19 restrictions" rel="bookmark">Other Voices: Be smart with the relaxing of COVID-19 restrictions</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/17/dg-martin-nc-natives-connection-to-chinas-arms-buildup/" title="Permalink to DG Martin: NC native’s connection  to China’s arms buildup" rel="bookmark">DG Martin: NC native’s connection  to China’s arms buildup</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_c24754ee9ca7c39e1d5b87941f432e70" style="overflow: hidden; min-width: 100%; border: none;" src="https://racing.ap.org/iframe/widgets/content/c24754ee9ca7c39e1d5b87941f432e70" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_c24754ee9ca7c39e1d5b87941f432e70');"></iframe>		</div></li>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST BUSINESS</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/19/author-agricultural-advocate-explores-pitfalls-of-food-marketing-during-salute-to-agri-business-event/" title="Permalink to Author, agricultural advocate explores pitfalls of food marketing during &#8216;Salute to Agri-Business&#8217; event" rel="bookmark">Author, agricultural advocate explores pitfalls of food marketing during &#8216;Salute to Agri-Business&#8217; event</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/18/with-new-location-in-charlotte-salisburys-mean-mug-coffee-starts-expansion/" title="Permalink to With new location in Charlotte, Salisbury&#8217;s Mean Mug Coffee starts expansion" rel="bookmark">With new location in Charlotte, Salisbury&#8217;s Mean Mug Coffee starts expansion</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/18/posts-building-back-on-the-market-after-parking-concerns/" title="Permalink to Post&#8217;s building back on the market after parking concerns" rel="bookmark">Post&#8217;s building back on the market after parking concerns</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/16/customer-service-company-hiring-in-rowan-county-officials-announce/" title="Permalink to Customer service company hiring in Rowan County" rel="bookmark">Customer service company hiring in Rowan County</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/16/across-the-pond-bed-and-breakfast-welcomes-guests-after-a-yearlong-pause/" title="Permalink to Across the Pond Bed and Breakfast welcomes guests after a yearlong pause" rel="bookmark">Across the Pond Bed and Breakfast welcomes guests after a yearlong pause</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
	<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-6'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-6'); });
  </script>
</div>		</div>
	</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-5" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST LIFESTYLE</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/14/patsy-flint-and-the-origin-of-the-rowan-history-class/" title="Permalink to Patsy Flint and the origin of the Rowan History Class" rel="bookmark">Patsy Flint and the origin of the Rowan History Class</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/14/ann-farabee-column-say-nice-things/" title="Permalink to Ann Farabee column: Say nice things" rel="bookmark">Ann Farabee column: Say nice things</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/14/removing-tree-at-hurley-park-proved-to-be-a-challenge/" title="Permalink to Pine tree uproots at Hurley Park as a result of excessive rainfall" rel="bookmark">Pine tree uproots at Hurley Park as a result of excessive rainfall</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/14/sharon-randall-column-the-promise-of-spring/" title="Permalink to Sharon Randall column: The promise of spring" rel="bookmark">Sharon Randall column: The promise of spring</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.salisburypost.com/2021/03/14/gotta-run-how-to-get-more-and-better-sleep/" title="Permalink to Gotta’ Run: How to get more and better sleep" rel="bookmark">Gotta’ Run: How to get more and better sleep</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		<a href="http://salisburypost.nc.newsmemory.com/ssindex.php">
			<img src="//www.salisburypost.com/wp-content/uploads/2016/10/special-section-bar-for-web300.jpg" alt="">
		</a>

		<br />
		<br />

		<script language="JavaScript" src="https://salisburypost.mycapture.com/datafeeds/28095.js"></script></div></li>
<li id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_bde00e4c8bdeeb4f1e1ee7efbf372056" style="overflow: hidden; min-width: 100%; border: none;" src="https://racing.ap.org/iframe/widgets/content/bde00e4c8bdeeb4f1e1ee7efbf372056" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_bde00e4c8bdeeb4f1e1ee7efbf372056');"></iframe></div></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  </ul>							</div>

							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/20/city-to-fill-abandoned-sewer-pipe-under-city-park-lake-after-leak/" rel="bookmark" title="City to fill abandoned sewer pipe under City Park Lake after leak">City to fill abandoned sewer pipe under City Park Lake after leak</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Elections</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/nc-federal-attorneys-24-more-charged-in-voter-fraud-probe/" rel="bookmark" title="NC federal attorneys: 24 more charged in voter-fraud probe">NC federal attorneys: 24 more charged in voter-fraud probe</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/nc-resident-among-four-proud-boys-charged-in-plot-to-attack-capitol/" rel="bookmark" title="NC resident among four Proud Boys charged in plot to attack Capitol">NC resident among four Proud Boys charged in plot to attack Capitol</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/more-than-3000-rowan-residents-received-vaccination-this-week/" rel="bookmark" title="More than 3,000 Rowan residents received vaccination this week">More than 3,000 Rowan residents received vaccination this week</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/pipe-replacement-requires-road-closure-in-eastern-rowan/" rel="bookmark" title="Pipe replacement requires road closure in eastern Rowan">Pipe replacement requires road closure in eastern Rowan</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/i-85-work-will-require-road-closures-next-week/" rel="bookmark" title="I-85 work will require road closures next week">I-85 work will require road closures next week</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/kannapolis-man-hospitalized-after-crashing-during-chase/" rel="bookmark" title="Kannapolis man hospitalized, faces charges after crashing during chase with sheriff&#8217;s deputies">Kannapolis man hospitalized, faces charges after crashing during chase with sheriff&#8217;s deputies</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Elections</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/ex-judge-cheri-beasley-to-run-for-u-s-senate-advisers-say/" rel="bookmark" title="Ex-judge Cheri Beasley to run for U.S. Senate, advisers say">Ex-judge Cheri Beasley to run for U.S. Senate, advisers say</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/38-new-covid-19-positives-nearly-400-new-vaccinations-reported-in-rowan/" rel="bookmark" title="38 new COVID-19 positives, nearly 400 new vaccinations reported in Rowan">38 new COVID-19 positives, nearly 400 new vaccinations reported in Rowan</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/historic-preservation-commission-approves-patio-fence-for-outdoor-dining-at-sweet-meadow-cafe/" rel="bookmark" title="Historic Preservation Commission approves patio, fence for outdoor dining at Sweet Meadow Café">Historic Preservation Commission approves patio, fence for outdoor dining at Sweet Meadow Café</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/blotter-salisbury-man-charged-with-felony-embezzlement/" rel="bookmark" title="Blotter: Salisbury man charged with felony embezzlement">Blotter: Salisbury man charged with felony embezzlement</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/author-agricultural-advocate-explores-pitfalls-of-food-marketing-during-salute-to-agri-business-event/" rel="bookmark" title="Author, agricultural advocate explores pitfalls of food marketing during &#8216;Salute to Agri-Business&#8217; event">Author, agricultural advocate explores pitfalls of food marketing during &#8216;Salute to Agri-Business&#8217; event</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/19/financial-incentive-for-more-medicaid-in-nc-draws-mixed-reaction/" rel="bookmark" title="Financial incentive for more Medicaid in NC draws mixed reaction">Financial incentive for more Medicaid in NC draws mixed reaction</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/biden-says-us-to-hit-100-million-vaccine-goal-today/" rel="bookmark" title="Biden says US to hit 100 million vaccine goal today">Biden says US to hit 100 million vaccine goal today</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/us-russia-ties-nosedive-after-biden-putin-tit-for-tat/" rel="bookmark" title="US-Russia ties nosedive after Biden-Putin tit-for-tat">US-Russia ties nosedive after Biden-Putin tit-for-tat</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/storms-send-tv-anchors-scrambling-off-set-in-nc/" rel="bookmark" title="Storms send TV anchors scrambling off set in NC">Storms send TV anchors scrambling off set in NC</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/man-charged-with-drug-possession-stealing-handgun/" rel="bookmark" title="Man charged with drug possession, stealing handgun">Man charged with drug possession, stealing handgun</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/gildan-employee-accidentally-causes-120000-in-damage/" rel="bookmark" title="Gildan employee accidentally causes $120,000 in damage">Gildan employee accidentally causes $120,000 in damage</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/sheriffs-deputy-involved-in-single-vehicle-crash/" rel="bookmark" title="Sheriff&#8217;s deputy involved in single-vehicle crash">Sheriff&#8217;s deputy involved in single-vehicle crash</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">East Spencer</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/east-spencer-woman-wins-1-million-lottery-prize/" rel="bookmark" title="East Spencer woman wins $1 million lottery prize">East Spencer woman wins $1 million lottery prize</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/band-attic-has-a-strong-year-during-a-pandemic-in-a-difficult-industry/" rel="bookmark" title="In Spencer, music store finds its groove">In Spencer, music store finds its groove</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/with-new-location-in-charlotte-salisburys-mean-mug-coffee-starts-expansion/" rel="bookmark" title="With new location in Charlotte, Salisbury&#8217;s Mean Mug Coffee starts expansion">With new location in Charlotte, Salisbury&#8217;s Mean Mug Coffee starts expansion</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">High School</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/friday-night-heroes-kennerly-helped-spark-offensive-outburst-for-falcons/" rel="bookmark" title="Friday night heroes: Kennerly helped spark offensive outburst for Falcons">Friday night heroes: Kennerly helped spark offensive outburst for Falcons</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://m.salisburypost.com/2021/03/18/council-approves-revised-downtown-main-street-plan-that-aims-to-address-locals-concerns/" rel="bookmark" title="Council approves revised Downtown Main Street plan that aims to address locals&#8217; concerns">Council approves revised Downtown Main Street plan that aims to address locals&#8217; concerns</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

						<div class="clearfix"></div>
					</div>
					<div id="footer" class="clearfix">

						<div id="footSections" class="col">
							
							<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://m.salisburypost.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://m.salisburypost.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://m.salisburypost.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://m.salisburypost.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://m.salisburypost.com/category/lifestyle/" title="" rel="bookmark"><span>Lifestyle</span></a></li>
								<li><a href="https://m.salisburypost.com/category/health/" title="" rel="bookmark"><span>Health</span></a></li>
								<li><a href="https://m.salisburypost.com/category/faith/" title="" rel="bookmark"><span>Faith</span></a></li>
								<li><a href="http://www.legacy.com/obituaries/salisburypost/" title="" rel="bookmark"><span>Obituaries</span></a></li>
								<li><a href="http://marketplace.salisburypost.com/adhunter/SalisburyPost/" title="" rel="bookmark"><span>Classifieds</span></a></li>
								<li><a href="http://video.salisburypost.com/" title="" rel="bookmark"><span>Video</span></a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
							
							<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://m.salisburypost.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
								<li><a href="https://m.salisburypost.com/customer-service/" title="" rel="bookmark">Contact Us</a></li>
								<li><a href="http://www.salisburypost.com/subscriptions/" title="" rel="nofollow">Subscribe</a></li>
								<li><a href="https://m.salisburypost.com/services/policies/" title="" rel="bookmark">Policies</a></li>
								<li><a href="https://m.salisburypost.com/services/policies/" title="" rel="nofollow">Terms of use</a></li>
								<li><a href="https://m.salisburypost.com/services/submit-a-news-tip/" title="" rel="nofollow">Submit a news tip</a></li>
								<li><a href="https://m.salisburypost.com/customer-service/" title="" rel="nofollow">Online Forms</a></li>
								<li><a href="https://m.salisburypost.com/editorial-social/" title="" rel="nofollow">Social Media</a></li>
								<li><a href="http://salisburypostnie.com/" title="" rel="nofollow">NIE - Newspapers In Education</a></li>
								<li><a href="http://salisburypost.mycapture.com/mycapture/index.asp" title="" rel="bookmark"><span>Purchase Photos</span></a></li>
				
								
															</ol>
						</div>


						<div id="footCopyright" class="col">
							


							<h4>Copyright</h4>
							<ol>
								<li>&copy; 2021, Salisbury Post</li>
							</ol>
						</div>

					</div>
				</div>

        <div id="mobile_footer_ad">
					<div class="ad">
						<!-- 320x50_mobile_sticky -->
<div id='div-gpt-ad-mobile-sticky'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-sticky'); });
  </script>
</div>					</div>
				</div>

				</div>

				<div class="sb-slidebar sb-left">
					<!-- Your left Slidebar content. -->
					<ul id="slidebarList">
					</ul>
				</div>


								<script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.js?1599406936"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.timeago.js"></script>
				<script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/vendor/readmore.min.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/plugins.js?1599406936"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni-mobile/media/js/main.js?1603155597"></script>

        

	
				
<script type="text/javascript">tb_pathToImage = "https://m.salisburypost.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://m.salisburypost.com/wp-includes/js/thickbox/tb-close.png";</script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/m.salisburypost.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://m.salisburypost.com/wp-includes/js/thickbox/thickbox.js?m=1615321600g'></script>
<script src='https://www.salisburypost.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.6' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://m.salisburypost.com/wp-includes/js/hoverintent-js.min.js?m=1615321601g'></script>
<script src='https://m.salisburypost.com/wp-includes/js/admin-bar.min.js?ver=5.7' id='admin-bar-js'></script>
<script id='admin-bar-js-after'>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {
		var searchValRegex = new RegExp( $(this).val(), 'i');
		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {
			return searchValRegex.test( $(this).find('> a').text() );
		}).show();
	});
});
</script>
<script id='wp-polls-js-extra'>
var pollsL10n = {"ajax_url":"https:\/\/m.salisburypost.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script src='https://www.salisburypost.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3' id='wp-polls-js'></script>
<script type='text/javascript' src='https://m.salisburypost.com/wp-includes/js/wp-embed.min.js?m=1615321601g'></script>
<script src='https://stats.wp.com/e-202111.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.5.2',blog:'170543381',post:'500823',tz:'-4',srv:'m.salisburypost.com'} ]);
	_stq.push([ 'clickTrackerInit', '170543381', '500823' ]);
</script>
				</div><!-- END undertone -->
            </body>
</html>